1 (изменено: snake, 27-06-2014 19:05:19)

Тема: ShowOperation(0) в TCS 6.3

Здравствуйте! В технологии TCS 6.3 обнаружилось, что

TCSActiveModule.ShowOperation (0)

не перемещает на корень дерева. Старый макрос работает некорректно. Что посоветуете?

2 (изменено: snake, 30-06-2014 09:13:56)

Re: ShowOperation(0) в TCS 6.3

Проверяю в техпроцессе

Sub Prov(TCSActiveModule)
TCSapp.ShowOneTreeNodeData = False  
TCSActiveModule.ShowOperation(0)
TCSActiveModule.First
tt= TCSActiveModule.Showmodal("Проверка ShowOperation (0)")
exit sub

Если перед запуском макроса в дереве стою на конкретной операции, то так на ней и остаюсь.
А что у Вас?

Re: ShowOperation(0) в TCS 6.3

не перемещает на корень дерева

Ну она не то чтобы на корень перемещалась, но работала по другому, да.

Будет исправление.

4 (изменено: snake, 30-06-2014 12:31:09)

Re: ShowOperation(0) в TCS 6.3

Согласна, это фильтр. А про корень написала, только чтобы отразить нашу проблему.
Будем ждать исправление!

5

Re: ShowOperation(0) в TCS 6.3

Добавила в код Refresh

Sub Prov(TCSActiveModule)
TCSapp.ShowOneTreeNodeData = False 
TCSActiveModule.ShowOperation(0)
TCSActiveModule.Refresh
'TCSActiveModule.First
tt= TCSActiveModule.Showmodal("Проверка ShowOperation (0)")
exit sub

и все отобразилось, как надо.
Но вы все равно ведь исправите? У нас есть другие старые макросы, в которых это может проявиться.

Re: ShowOperation(0) в TCS 6.3

Но вы все равно ведь исправите?

Да, конечно исправим. Подобные ошибки могут появиться и в других местах. Переделывали эти места в 6.3 просто.

Re: ShowOperation(0) в TCS 6.3

www.technologics.ru/news/90-pake … 19100.html

Спасибо сказали: snake1